Modify

#14156 closed defect (duplicate)

KeyError: 'trac_auth' in Trac 1.5 / Python 3

Reported by: roger Owned by: Cinc-th
Priority: normal Component: TracWikiPrintPlugin
Severity: normal Keywords:
Cc: Trac Release:

Description

When I select any of the PDF options at the bottom of a wiki page, I get the error KeyError: 'trac_auth'.

I have WIKIPRINT_ADMIN permissions. I don't think that's the issue. If I select PDF Page (custom settings), I get the settings dialog. It is when I choose Download that it fails.

How to Reproduce

While doing a GET operation on /wiki/WikiStart, Trac issued an internal error.

Request parameters:

{'download': '1',
 'footertext': '[page] / [topage]',
 'format': 'pdfpage',
 'page': 'WikiStart',
 'pagesize': 'A4',
 'pdftitle': 'qqq',
 'stylepage': ''}

User agent: Mozilla/5.0 (X11; Linux x86_64; rv:104.0) Gecko/20100101 Firefox/104.0

System Information

Trac 1.5.4.dev0
Babel 2.10.3
Docutils 0.17.1
Jinja2 3.1.2
mod_wsgi 4.9.2 (WSGIProcessGroup WSGIApplicationGroup %{GLOBAL})
Pygments 2.13.0
pysqlite 2.6.0
Python 3.10.6 (main, Aug 02 2022, 17:22:31) [GCC]
pytz 2022.1
setuptools 63.2.0
SQLite 3.39.3
Subversion 1.14.2 (r1899510)
Textile 4.0.2
jQuery 3.6.0
jQuery UI 1.13.0
jQuery Timepicker 1.6.3

Enabled Plugins

AllAttachmentsMacro N/A
ASCIIMath 1.0-r15929
CSV 1.0-r16768
MilestoneQuery 1.1.0
NewTicketSubscriber N/A
NoteBox 1.0
TracChildTickets 2.6.0.dev0
TracCollapsiblePlugin 0.1
TracDownloads 1.4.0
TracFootNoteMacro 1.6.1
TracGraphviz 1.4.0.2.dev0
TracHtmlNotificationPlugin 0.12.0.3
TracIncludeMacro 3.3.0.dev0
TracLatex 0.2.dev0
TracSumFields 2.0.0.dev0
TracWikiPrint 4.0.0.dev0
TracWysiwyg 0.12.0.7
TracXMLRPC 1.2.0.dev0
upcomingmilestoneschartmacro 1.0 (Rev)

Interface Customization

shared-htdocs
shared-templates
site-htdocs latex-images, ramboll_intranet.gif, site.html, sorttable.js, style.css, tracworkflowadmin
site-templates site.html

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python3.10/site-packages/Trac-1.5.4.dev0-py3.10.egg/trac/web/main.py", line 610, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python3.10/site-packages/Trac-1.5.4.dev0-py3.10.egg/trac/web/main.py", line 302, in dispatch
    raise e
  File "/usr/lib/python3.10/site-packages/Trac-1.5.4.dev0-py3.10.egg/trac/web/main.py", line 248, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python3.10/site-packages/Trac-1.5.4.dev0-py3.10.egg/trac/wiki/web_ui.py", line 184, in process_request
    Mimeview(self.env).send_converted(req, 'text/x-trac-wiki',
  File "/usr/lib/python3.10/site-packages/Trac-1.5.4.dev0-py3.10.egg/trac/mimeview/api.py", line 1039, in send_converted
    content, output_type, ext = self.convert_content(req, in_type, content,
  File "/usr/lib/python3.10/site-packages/Trac-1.5.4.dev0-py3.10.egg/trac/mimeview/api.py", line 712, in convert_content
    output = conversion.converter.convert_content(req, mimetype,
  File "/usr/lib/python3.10/site-packages/TracWikiPrint-4.0.0.dev0-py3.10.egg/tracpdf/wikiprint.py", line 218, in convert_content
    pdfoptions = self.prepare_pdf_options(req, pagename)
  File "/usr/lib/python3.10/site-packages/TracWikiPrint-4.0.0.dev0-py3.10.egg/tracpdf/wikiprint.py", line 261, in prepare_pdf_options
    ('trac_auth', req.incookie['trac_auth'].value),
KeyError: 'trac_auth'

Attachments (0)

Change History (1)

comment:1 Changed 19 months ago by Jun Omae

Keywords: pdf print python3 Trac1.5.4 removed
Resolution: duplicate
Status: newclosed

A duplicate of #14087.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Cinc-th.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.