Modify

Opened 10 years ago

Closed 10 years ago

#1702 closed defect (duplicate)

update failed

Reported by: diley@… Owned by: Colin Guthrie
Priority: normal Component: WorkLogPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

after installing the WorkLogPlugin a update of the database is needed.
message:
update failed .... -> field 'time'

Attachments (0)

Change History (4)

comment:1 Changed 10 years ago by Colin Guthrie

Oooh! My first customer!

Which revision are you using?

I don't have any field named time with the latest revision!

That said, did you run trac-admin /path/to/trac upgrade after the install?

I forgot to mention that on my Wiki page, which I'll add now :)

Col

comment:2 Changed 10 years ago by Colin Guthrie

Resolution: fixed
Status: newclosed

OK, I've just checked and it works fine after running the trac-admin upgrade.

I was using a column name called time in an older version but this has since been dropped. This may have caused problems with older sqlite versions (tested on 3.4.0) and with other db backends.

Not tested on postgres or mysql but hopefully it should work.

Closing for now as it seems to work for me, but reopen with more info if the latest version causes you problems.

Cheers.

comment:3 Changed 10 years ago by anonymous

Resolution: fixed
Status: closedreopened

I've got an error while executing trac-admin upgrade:

Worklog needs an upgrade
Upgrading usermanual
Command failed: 'builtin_function_or_method' object has no attribute 'time'

comment:4 Changed 10 years ago by Colin Guthrie

Resolution: duplicate
Status: reopenedclosed

Duplicate of #1710 (I know it's a later ticket, but it's got more info on it).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Colin Guthrie.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.