Modify

Opened 8 years ago

Closed 6 years ago

#5165 closed defect (duplicate)

Group permissions not working

Reported by: anonymous Owned by: Noah Kantrowitz
Priority: high Component: PrivateTicketsPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description (last modified by Ryan J Ollos)

I installed and set up Privatetickets plugin and was able to get the user permission configured but group permissions seem to be having an issue.

I create a user Itest and asssign the following permissions: Report_view, Ticket_Create, Ticket_modify, ticket_append, Ticket_chgprop, ticket_view, ticket_view_cc, Ticker_view_owner, Ticker_view_reporter, ticket_viewReporter_group

I also added them to the group Test.

I create user2 with the following permissions

Ticket_view, Ticket_view_cc, ticket_view_cc_group, ticket_view_group, ticket_view_owner_group, ticket_view_reporter, ticker_view_reporter_group, report_view

Add this user to group test.

user2 is unable to see tickets created assigned to user ITest or tickets where ITest is in the CC list.

Attachments (0)

Change History (3)

comment:1 Changed 8 years ago by anonymous

i'm having the same problem, did you ever get this resolved?

comment:2 Changed 7 years ago by anonymous

according to #3222, group name should in all lower-case

comment:3 Changed 6 years ago by Ryan J Ollos

Description: modified (diff)
Resolution: duplicate
Status: newclosed

Assuming your group name is Test and not test (you say both), then this is a duplicate of #3222, as suggested in comment:2.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Noah Kantrowitz.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.