Modify

Opened 8 years ago

Last modified 3 years ago

#5484 assigned defect

[Patch] unicode support and multirepos support

Reported by: KlauX Owned by: Ryan J Ollos
Priority: normal Component: SvnAuthzAdminPlugin
Severity: normal Keywords:
Cc: klaux1@…, dmcr@… Trac Release: 0.11

Description (last modified by Ryan J Ollos)

The attached patch adds two capabilities to SvnAnthzAdminPlugin for Trac 0.11.x:

  • unicode support
  • multirepos support

For unicode support I remove urllib dependence.

Attachments (1)

svnauthzadminplugin_0.11.patch (7.2 KB) - added by KlauX 8 years ago.
for unicode support and multirepos support

Download all attachments as: .zip

Change History (7)

Changed 8 years ago by KlauX

for unicode support and multirepos support

comment:1 Changed 8 years ago by rupert thurner

could you pls update the patch to use only existing directories, and the current status of admin_ui?

comment:2 Changed 6 years ago by Ryan J Ollos

Description: modified (diff)
Summary: unicode support and multirepos support[Patch] unicode support and multirepos support

comment:3 Changed 6 years ago by Ryan J Ollos

See also #5484 and #7348.

comment:4 Changed 6 years ago by Ryan J Ollos

Cc: klaux1@… dmcr@… added; klaux1@… removed

#8165 closed as duplicate. Adding reporter of #8165 to CC list.

comment:5 Changed 6 years ago by dmcr@…

This is not a duplicate of #8165.

What the author of *this* patch means by "multirepos support", has already been implemented in the latest version of this plugin as the 'show_all_repos' feature.

The rest of the patch is a duplicate of #7871, but I don't use Unicode, so can't verify if these patches are correct.

Dennis

comment:6 Changed 3 years ago by Ryan J Ollos

Owner: changed from Kis Gergely to Ryan J Ollos
Status: newassigned

Modify Ticket

Action
as assigned The owner will remain Ryan J Ollos.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.