Modify

Opened 7 years ago

Closed 4 years ago

#5920 closed defect (worksforme)

Can't create new tickets with Eclipse

Reported by: anonymous Owned by: jeangui
Priority: normal Component: DefaultCcPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description (last modified by rjollos)

This plugin do not work together with the latest XMLRPC update and Eclipse/Mylyn. If i create a new ticket i get always the following error:

2009-10-05 12:46:34,194 Trac[web_ui] ERROR: columns ticket, time, field are not unique
2009-10-05 12:46:34,210 Trac[web_ui] ERROR: Traceback (most recent call last):
  File "build\bdist.win32\egg\tracrpc\web_ui.py", line 173, in process_xml_request
    result = XMLRPCSystem(self.env).get_method(method)(req, args)
  File "build\bdist.win32\egg\tracrpc\api.py", line 94, in __call__
    result = self.callable(req, *args)
  File "build\bdist.win32\egg\tracrpc\ticket.py", line 149, in create
    listener.ticket_created(t)
  File "build\bdist.win32\egg\defaultcc\main.py", line 43, in ticket_created
    ticket.save_changes('DefaultCC Plugin', '')
  File "C:\Python25\lib\site-packages\trac\ticket\model.py", line 265, in save_changes
    self[name]))
  File "C:\Python25\lib\site-packages\trac\db\util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "C:\Python25\lib\site-packages\trac\db\sqlite_backend.py", line 58, in execute
    args or [])
  File "C:\Python25\lib\site-packages\trac\db\sqlite_backend.py", line 50, in _rollback_on_error
    return function(self, *args, **kwargs)
IntegrityError: columns ticket, time, field are not unique

The problem is gone after i disabled the plugin.

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by anonymous

I created the ticket with the Mylyn GUI within Eclipse.

comment:2 Changed 4 years ago by rjollos

  • Description modified (diff)

comment:3 Changed 4 years ago by anonymous

  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce with either the 0.1 version (r5293) or the latest trunk r11750. If there was an issue that takes some special conditions to reproduce, it may have been fixed in #4919 anyway.

Please reopen if you wish to continue debugging the issue.

Add Comment

Modify Ticket

Action
as closed The owner will remain jeangui.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.