Modify

Opened 14 years ago

Closed 10 years ago

Last modified 10 years ago

#6529 closed defect (fixed)

[Patch] Anchors are reported as missing links

Reported by: gertjan.zwartjes@… Owned by: Ryan J Ollos
Priority: normal Component: WantedPagesMacro
Severity: normal Keywords: patch
Cc: Itamar Ostricher Trac Release: 0.11

Description

For pages that have anchors defined in their section headers, e.g.

== Site Appearance == #SiteAppearance

the WantedPages plugin will report a missing link, in this case for the SiteAppearance anchor.

Attachments (1)

wantedpagesplugin-ignore-anchors.patch (648 bytes) - added by gertjan.zwartjes@… 14 years ago.
Patch for ignoring anchors

Download all attachments as: .zip

Change History (14)

Changed 14 years ago by gertjan.zwartjes@…

Patch for ignoring anchors

comment:1 Changed 14 years ago by anonymous

I tried to fix this by editing the regular expression for camel case link matching, see attached patch. It works for me, but it might be better for the original author to check whether this is the right fix.

comment:2 Changed 14 years ago by Ryan J Ollos

Summary: Anchors are reported as missing links[Patch] Anchors are reported as missing links

comment:3 Changed 13 years ago by Itamar Ostricher

Cc: Itamar Ostricher added; anonymous removed
Keywords: patch added

Thanks for the patch!

Just started using it, and looks like it does the job.

Any chance it gets into trunk?

comment:4 Changed 12 years ago by Ryan J Ollos

Ping me if we don't here from the author for two weeks and I'll make sure it gets into the repository.

comment:5 in reply to:  4 Changed 10 years ago by Geert

Replying to rjollos:

Ping me if we don't here from the author for two weeks and I'll make sure it gets into the repository.

Ping...

comment:6 Changed 10 years ago by Ryan J Ollos

Owner: changed from Justin Francis to Ryan J Ollos
Status: newaccepted

comment:7 Changed 10 years ago by Ryan J Ollos

Resolution: fixed
Status: acceptedclosed

In 13561:

Ignore CamelCase words that are anchors. Fixes #6529.

comment:8 Changed 10 years ago by Ryan J Ollos

I did not test the change, but it looks straightforward enough. Please report back if it is working for you now after installing from wantedpagesplugin/trunk.

comment:9 Changed 10 years ago by Geert

Works for me. Thanks.

Please also close #7708, it's a duplicate of this ticket.

comment:10 Changed 10 years ago by Ryan J Ollos

#7708 closed as a duplicate.

comment:11 in reply to:  10 ; Changed 10 years ago by Geert

Replying to rjollos:

#7708 closed as a duplicate.

FYI: Instead of closing ticket #7708, you assigned it to yourself.

Question: Is the original author of this plugin still interested in maintaining it or can I adopt it?

comment:12 in reply to:  11 Changed 10 years ago by Ryan J Ollos

Replying to glinders:

Question: Is the original author of this plugin still interested in maintaining it or can I adopt it?

No activity from the original author in 6 years, but there was a response in #10502. Feel free to proceed with a formal adoption request, see AdoptingHacks.

I was planning to push some changes, but I'd be happy to have someone else do it :)

comment:13 Changed 10 years ago by Ryan J Ollos

Component: WantedPagesPluginWantedPagesMacro

Renaming plugin from WantedPagesPlugin to WantedPagesMacro.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.