Modify

Opened 7 years ago

Closed 3 years ago

#7218 closed enhancement (duplicate)

Improvements of TicketValidator plugin - requested features and more implemented

Reported by: Reinhard Wobst Owned by: Max Stewart
Priority: normal Component: TicketValidatorPlugin
Severity: normal Keywords: validator plugin, type field, status field
Cc: Trac Release: 0.11

Description

In short, fields may now be required

  • for any state (as requested in ticket:4742)
  • and/or for any or certain type (as requested in ticket:6067)
  • and be string, or integer, or float (or more ...)

... and error messages were improved (show field label instead of field name, don't check fields which are not contained in the ticket but configured in trac.ini for validator plugin).

All details can be found in validator.txt.

Reinhard

Attachments (1)

ticketvalidator.zip (19.3 KB) - added by Reinhard Wobst 7 years ago.
TicketValidator plugin 0.2.1

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by Reinhard Wobst

Attachment: ticketvalidator.zip added

TicketValidator plugin 0.2.1

comment:1 Changed 6 years ago by Reinhard Wobst

By a mistake, I re-posted this Ticket under #8897 - it has the same software as base. Sorry.

comment:2 Changed 3 years ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

Duplicate of #8897.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Max Stewart.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.