Modify

Opened 5 years ago

Closed 4 years ago

#9686 closed defect (duplicate)

Incompatibility with 0.12 or higher

Reported by: fowie Owned by: Stefan Simroth
Priority: high Component: GoogleCalendarPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.12

Description

0.12 no longer contains the clearsilver compatability code, so enabling the GoogleCalendar plugin on a 0.12 system now gives

AssertionError: HDF dataset not available. Check your clearsilver installation

Any chance of this being fixed?

Attachments (0)

Change History (6)

comment:1 in reply to:  description ; Changed 5 years ago by Stefan Simroth

Summary: Incompatability with 0.12?Incompatibility with 0.12
Trac Release: 0.110.12

Replying to fowie:

Any chance of this being fixed?

Not by me, I'm sorry to say. But anyone who wants to submit a patch is very welcome. All the plugin does is add an iframe with the calendar url.

comment:2 Changed 5 years ago by Stefan Simroth

To achieve compatibility, it would basically mean to remove the clearsilver dependency as stated in #8128

comment:3 in reply to:  1 Changed 5 years ago by Ryan J Ollos

Replying to StefanSimroth:

All the plugin does is add an iframe with the calendar url.

If that is the case, you might want to take a look at TracTabPlugin for an alternative.

comment:4 Changed 5 years ago by Stefan Simroth

Summary: Incompatibility with 0.12Incompatibility with 0.12 or higher

see #8915 for exception on 0.13

comment:5 Changed 5 years ago by Stefan Simroth

Priority: normalhigh
Severity: normalblocker

comment:6 Changed 4 years ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

Duplicate of #8128. On 0.12, you can install ClearSilver. However, for Trac >= 1.0, all ClearSilver support has been dropped.

Modify Ticket

Action
as closed The owner will remain Stefan Simroth.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.