Modify

Opened 2 years ago

Closed 12 months ago

#10417 closed enhancement (duplicate)

XML RPC to fix incompatible autocompletion plugins

Reported by: fommil Owned by: rjollos
Priority: normal Component: AutocompleteUsersPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description

(this is writing up a private email exchange from when TH was down, hence jumping to conclusions)

Please extend this plugin to work for all ticket fields, TagsPlugin and a few other input fields by using the XmlRpcPlugin and a standardised version of jQuery. There are currently many autocomplete plugins which are all competing with each other, using incompatible jQuery versions, and using their own backend systems.

A clean XML-RPC approach would reuse existing functionality and make the user experience excellent – I'd even push to get such a plugin included as a part of core trac.

Attachments (0)

Change History (1)

comment:1 Changed 12 months ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed
  • Autocompleting other fields has been requested in #6444.
  • Porting the plugin to a recent version of jQuery UI will be handled in #9599.

Therefore, closing as a duplicate of #6444 and #9599.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.