Modify

Opened 19 months ago

Closed 11 days ago

#10416 closed enhancement (fixed)

Tag keyword shorthand syntax

Reported by: fommil Owned by: hasienda
Priority: normal Component: TagsPlugin
Severity: normal Keywords: wiki tag provider syntax alternative
Cc: Trac Release: 1.0

Description

Please provide a shorthand syntax like WikiCreateTicketPlugin for adding keyword tags to a page.

example: #mytag #myothertag on the first line. This would be parsed and removed from the wiki page text, adding the keywords to the wiki keyword tags.

Attachments (0)

Change History (4)

comment:1 Changed 19 months ago by hasienda

  • Keywords wiki tag provider syntax alternative added

I'd currently refrain from using such a markup as primary tag source.

When working on performance issues for the ticket tags provider I realized, that normalized tag storage is critical to decent system performance. Harvesting the keywords ticket field turned out to be a major performance hog, i.e. waiting 15 s/30.000 tickets. Envision to have 500.000+ tickets, like i.e. the Debian BTS, this would be totally unacceptable.

So while harvesting all wiki pages for tags would help with missing tag versions support (#2429), I can't think of a way to do that i.e. on each call to the /tags main page. But this is the current state. What I want to outline: This can't happen on current code, but depends on advanced features like a tag cache etc., that we'll need to work out first.

Side note: Prior to tags-0.6 we had TagIt wiki macro, that served a similar purpose.

comment:2 Changed 8 weeks ago by rjollos

I could imagine using IWikiPageManipulator to strip out the tag markup #mytag #myothertag and insert them into the tags field when the page is saved. However, this could result in unexpected behavior when users enter words corresponding to tag markup that are not intended to be tags, and the existing behavior of having a dedicated tags field on each page is really much cleaner.

My recommendation is to close this ticket as wontfix.

Last edited 8 weeks ago by rjollos (previous) (diff)

comment:3 Changed 8 weeks ago by hasienda

#2429 has made tremendous progress towards a production solution, so missing tag version support is no longer an excuse for this demand.

At second look the OP demand has never asked for adding keywords from inside a wiki page (effectively resurrecting former TagIt) but for adding new metadata on wiki page creation time, right? This has already been done during development for #3753. Call an URL

'<trac-with-tagsplugin-trunk>/wiki/NewTestPage?action=edit&tags=test'

to see it.

As a conclusion I suggest to close this ticket as fixed by the next release, if the OP does not disagree meanwhile.

Last edited 8 weeks ago by hasienda (previous) (diff)

comment:4 Changed 11 days ago by hasienda

  • Resolution set to fixed
  • Status changed from new to closed

In 13815:

TagsPlugin: Completing preparation for v0.7 release.

Availability of that code as stable, tagged release
closes #2429, #3359, #3610, #3624, #3677, #3754, #3864, #3947, #3983, #4078, #4277, #4503, #4799, #5523, #7787, #7857, #8638, #9057, #9058, #9059, #9060, #9061, #9062, #9063, #9149, #9210, #9521, #9630, #9636, #10032, #10416, #10636, #11096, #11147, #11152, #11274, #11302, #11658 and #11659.

Additionally there are some issues and enhancement requests showing progress,
but known to require more work to resolve them satisfactorily, specifically
refs #2804, #4200, #8747 and #9064.

Thanks to all contributors and followers, that enabled and encouraged a good
portion of this development work.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from hasienda. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.