Modify

Opened 3 years ago

Closed 2 years ago

#9052 closed defect (fixed)

Account Manager Plugin - acct_mgr.web_ui.emailverificationmodule - Doesn't send email

Reported by: anonymous Owned by: hasienda
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords: needinfo email notification
Cc: rjollos Trac Release: 0.11

Description

Other parts of my Trac install seem to email notices (ticket changes, etcetera). Is there something required to get new account or password reset emails? The email verification module doesn't seem to do it.

Attachments (0)

Change History (9)

comment:1 Changed 3 years ago by hasienda

  • Keywords email notification added

Email addresses to send these notices to are required. You can configure at the accountnotification admin page. What are your current settings in [account-manager] section of trac.ini?

comment:2 Changed 3 years ago by hasienda

BTW: What I dislike most about this ticket (and others) is anonymous reporter combined with high priority rating. As developer/maintainer I've no guarantee to ever get in contact, receive feedback on my questions and suggestions, no matter how fast and hard I try to support. That's inappropriate behavior, you see?

comment:3 Changed 3 years ago by hasienda

My 1st comment, simplified: Do you have at least the following lines with appropriate values in your trac.ini?

[account-manager]
account_changes_notify_addresses = admin@myaddress
notify_actions = new,change,delete

[components]
acct_mgr.api.* = enabled
acct_mgr.notification.* = enabled

comment:4 Changed 3 years ago by rjollos

  • Cc rjollos added; anonymous removed

comment:5 in reply to: ↑ description Changed 2 years ago by hasienda

Replying to anonymous:

Other parts of my Trac install seem to email notices (ticket changes, etcetera). Is there something required to get new account or password reset emails? The email verification module doesn't seem to do it.

Another source of confusion: New users are required to login, before the verification emails is sent to them.

comment:6 Changed 2 years ago by hasienda

  • Keywords needinfo added
  • Priority changed from high to normal

Due to missing response for almost 1 1/2 year this ticket is stepped down priority-wise and will get closed on acct_mgr-0.4 release.

Note, that #9090 might be relevant here too.

comment:7 Changed 2 years ago by hasienda

(In [12384]) AccountManagerPlugin: Follow-up to [12137] with a modified error class, refs #7577, #9052 and #9090.

The new RegistrationError class definition requires minor changes to existing IAccountRegistrationInspector implementations, but I couldn't find an easier way to preserve additional arguments for string substition until after deferred message string translation.

I've done changes in all message catalogs accounting for the tiny msgid change right-away to obsolete further action by individual translators.

Finally I'm registering resolution for two more tickets after testing account change notification with a more recent AnnouncerPlugin version successfully.

comment:8 Changed 2 years ago by hasienda

(In [12385]) AccountManagerPlugin: Add import missing from admin code after [12384], refs #7577, #9052, #9090 and #9940.

comment:9 Changed 2 years ago by hasienda

  • Resolution set to fixed
  • Status changed from new to closed

(In [12398]) AccountManagerPlugin: Releasing version 0.4, pushing development to acct_mgr-0.5dev.

Availability of that code as stable release closes #874, #3459, #4677, #5295, #5691, #6616, #7577, #8076, #8685, #8770, #8791, #8990, #9052, #9079, #9090, #9139, #9246, #9252, #9547, #9618, #9676, #9843, #9852, #9940, #10023, #10028, #10123, #10142, #10204, #10276, #10397, #10412, #10594, #10625 and #10644.

Some more issues have been worked-on, yet without confirmed resolution, refs #5464 (for JiraToTracIntegration), #8927 and #10134.

And finally there are some issues and enhancement requests showing progress, but known to require more work to resolve them satisfactorily, refs #843, #1600, #5964, #8217, #8933.

Thanks to all contributors and followers, that enabled and encouraged a good portion of this development work.

Add Comment

Modify Ticket

Action
as closed The owner will remain hasienda.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.