Modify

Opened 6 years ago

Closed 22 months ago

#3459 closed defect (fixed)

htpasswd/tracd/trac11 Authentication information not available

Reported by: cantthinkthinkpink@… Owned by: hasienda
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords: Tracd/Htpasswd
Cc: Trac Release: 0.11

Description

I have Trac 0.11 running on tracd, the standalone server. I had not previously configured any sort of login for trac. In order to get to my webAdmin,I added WEB_ADMIN permission for anonymous. A real hack, one which I hope to rid myself of soon.

I downloaded tracaccountmanager and enabled all components. I am now allowed to create and edit users, but when I click "login", I am given the error

Trac Error
Authentication information not available. Please refer to the installation documentation.

Does anyone have any ideas as to what I am doing wrong?

Attachments (0)

Change History (8)

comment:1 Changed 6 years ago by ermo

I did the exact same thing as you and searched high and low for a solution. I finally got it to work by setting the following options in trac.ini (inspired by #2725):

[components]
acct_mgr.* = enabled
trac.web.auth.loginmodule = disabled

This disables the standard login module which is normally loaded by tracstandalone.py and enables the AccountManager replacement login module. The instructions in the relevant section on the !AccountManager page are not entirely obvious, I'm afraid.

HTH

comment:2 follow-up: Changed 6 years ago by pacopablo

  • Resolution set to worksforme
  • Status changed from new to closed

Added a link at the top of the Account manager page to the login module documentation.

Additionally, you can use the --basic-auth or --auth options to tracd

comment:3 in reply to: ↑ 2 Changed 6 years ago by anonymous

Replying to pacopablo:

Added a link at the top of the Account manager page to the login module documentation.

Additionally, you can use the --basic-auth or --auth options to tracd

This should be more 'out of the box' - people shouldn't spend days hunting for this information. Bulky, scattered documentation is no substitute for short coding! :P

Also, --auth options for TracD are useless - they require you to place all env names on the command line and amend them for every new instance - there is no true wildcard for some odd reason.

comment:4 Changed 3 years ago by anonymous

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I am also facing this issue 0.12 version
Done

[components]
acct_mgr.* = enabled
trac.web.auth.loginmodule = disabled

comment:5 Changed 3 years ago by rjollos

  • Owner changed from mgood to hasienda
  • Status changed from reopened to new

comment:6 Changed 3 years ago by hasienda

  • Priority changed from high to normal

The wiki documentation has been clarified, extended, restructured, etc., especially since 2010. There is now a rather prominent quick-start and a dedicated CookBook/AccountManagerPluginConfiguration page. In my eyes, this has not only be a significant effort, but really improved setup procedure.

Anyway, I'm open to suggestions, how to further improve this status. If there's more substantial critics I could even decide to increase priority again. Regarding initial-setup-procedure you may rather want to comment to #8930 than to this old ticket.

IMHO it's a bit too easy to reopen with a weak me too statement. Consider contributions, please. After all the docs are a wiki, and patches are welcome for improving the code as well. So what's your specific issue?

Btw, there's no such thing like WEB_ADMIN permission anymore...

comment:7 Changed 2 years ago by hasienda

(In [11943]): AccountManagerPlugin: Fix trac.ini instead of taking own LoginModule down, refs #3459.

Despite of current documentation pointing at this potential issue in several places, this is a recurring topic, so preempting admin action seems like a common, uncontradicted demand.

comment:8 Changed 22 months ago by hasienda

  • Resolution set to fixed
  • Status changed from new to closed

(In [12398]) AccountManagerPlugin: Releasing version 0.4, pushing development to acct_mgr-0.5dev.

Availability of that code as stable release
closes #874, #3459, #4677, #5295, #5691, #6616, #7577, #8076, #8685, #8770, #8791, #8990, #9052, #9079, #9090, #9139, #9246, #9252, #9547, #9618, #9676, #9843, #9852, #9940, #10023, #10028, #10123, #10142, #10204, #10276, #10397, #10412, #10594, #10625 and #10644.

Some more issues have been worked-on, yet without confirmed resolution,
refs #5464 (for JiraToTracIntegration), #8927 and #10134.

And finally there are some issues and enhancement requests showing progress,
but known to require more work to resolve them satisfactorily,
refs #843, #1600, #5964, #8217, #8933.

Thanks to all contributors and followers, that enabled and encouraged a good
portion of this development work.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.