Modify

Opened 3 years ago

Closed 22 months ago

#11888 closed enhancement (fixed)

Show correct permission error instead of 'No handler matched ...'

Reported by: Steffen Hoffmann Owned by: Steffen Hoffmann
Priority: normal Component: TagsPlugin
Severity: minor Keywords: permission
Cc: Ryan J Ollos Trac Release: 0.11

Description

Requests to plugin pages ('/tags*') should yield a permission error, if lacking TAGS_VIEW instead of the following (current behavior):

No handler matched request to /tags

Attachments (0)

Change History (4)

comment:1 Changed 3 years ago by Steffen Hoffmann

Summary: Show correct permission error instead ofShow correct permission error instead of 'No handler matched ...'

comment:2 Changed 3 years ago by Steffen Hoffmann

In 14041:

TagsPlugin: Unhide missing permission as root cause for inacessible plugin pages, refs #11888.

Delayed, non-redundant permission check prevents 'No handler matched request'
error.

comment:3 Changed 3 years ago by Steffen Hoffmann

In 14146:

TagsPlugin: Update unit tests, refs #11695, #11888 and #11954.

Added test for anonymous ticket creation and change request as follow-up to
[14144]. Thanks to Jun Omae for contributing to this part.
Removed test for permisson error on illegitimate request obsoleted by [14041].

comment:4 Changed 22 months ago by Ryan J Ollos

Resolution: fixed
Status: newclosed

In 14945:

0.8: Tag 0.8 release

Fixes #1304, #1344, #3660, #3891, #9064, #9797, #11661, #11690, #11695, #11888, #11950, #11954, #11968, #12202, #12292, #12434, #12486.

Refs #12415.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Steffen Hoffmann.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.