Modify

Opened 3 years ago

Closed 14 months ago

#11695 closed defect (fixed)

Changes to tags may be recorded as anonymous

Reported by: rjollos Owned by: hasienda
Priority: normal Component: TagsPlugin
Severity: normal Keywords:
Cc: Trac Release:

Description

If a wiki page is edited by an unauthenticated user who enters a username in the author field (a behavior which was discussed in #11622), the wiki edit will be recorded as the entered user, but the change to the tag will be recorded as author anonymous. For an example, see wiki/PrivateTicketsPlugin.

Attachments (0)

Change History (6)

comment:1 Changed 3 years ago by hasienda

Am I right assuming, that following the discussion in #11622 we shall record authenticated session status and the session ID (sid) instead?

Last edited 3 years ago by hasienda (previous) (diff)

comment:2 Changed 3 years ago by hasienda

In 13862:

TagsPlugin: Improve tag change author detection, refs #11695.

comment:3 Changed 3 years ago by hasienda

Still I feel uneasy about not recording the authenticated session status in tags_change db table, even if not different from other, similar author records.

Last edited 2 years ago by hasienda (previous) (diff)

comment:4 Changed 2 years ago by hasienda

In 14144:

TagsPlugin: Improve request object mockup, refs #11695 and #11954.

Thanks to bobhy for reporting the error on anonymous ticket creation.
The issue has been caused by using get_reporter_id() from trac.util for
better author detection since [13862] without paying attention to the
additional attributes it actually tries to get on anonymous changes.

comment:5 Changed 2 years ago by hasienda

In 14146:

TagsPlugin: Update unit tests, refs #11695, #11888 and #11954.

Added test for anonymous ticket creation and change request as follow-up to
[14144]. Thanks to Jun Omae for contributing to this part.
Removed test for permisson error on illegitimate request obsoleted by [14041].

comment:6 Changed 14 months ago by rjollos

  • Resolution set to fixed
  • Status changed from new to closed

In 14945:

0.8: Tag 0.8 release

Fixes #1304, #1344, #3660, #3891, #9064, #9797, #11661, #11690, #11695, #11888, #11950, #11954, #11968, #12202, #12292, #12434, #12486.

Refs #12415.

Add Comment

Modify Ticket

Action
as closed The owner will remain hasienda.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.