Modify

Opened 3 years ago

Closed 5 months ago

#9149 closed defect (fixed)

Adding tags causes the wiki page content to not save

Reported by: mishra.anadi@… Owned by: hasienda
Priority: low Component: TagsPlugin
Severity: major Keywords: needinfo wiki change
Cc: rjollos, otaku42 Trac Release: 0.11

Description

Some of our users reported trac wiki pages not getting saved when using tags in the keyword field. When we removed the Tags Plugin, it worked fine.
This was really severe for some users as they typed a big document, added a few keywords and all the changes to the wiki page were lost when they hit submit button. Very frustrating.

We need tagging in our wiki, but prefer not to install this plugin. Please help.

Attachments (0)

Change History (9)

comment:1 in reply to: ↑ description Changed 3 years ago by hasienda

  • Keywords needinfo added
  • Priority changed from highest to high

Replying to mishra.anadi@gmail.com:

Some of our users reported trac wiki pages not getting saved when using tags in the keyword field. When we removed the Tags Plugin, it worked fine.
This was really severe for some users as they typed a big document, added a few keywords and all the changes to the wiki page were lost when they hit submit button. Very frustrating.

We need tagging in our wiki, but prefer not to install this plugin. Please help.

Interesting. For now let's assume you're not here for a rant but really for help (a bit hard to tell right now, sorry).

1st, please don't rate to high without proper information available. By now everything is unsure. "Works without TagsPlugin" means not much without other details. Could be another plugin interfering with TagsPlugin. At least consider, that many applications around the world use this plugin on a daily base in production. Certainly we've to find out, why not in your application.

2nd, facts, and facts again. Tell us your Trac version as well as full list of plugins installed. What (exact) revision of TagsPlugin did you use. Would you be so kind as to reproduce with DEBUG logging enabled and attach relevant parts of the logs here; Trac environment startup would be interesting and output from call to edit until POST to save wiki page.

3rd, let us agree on the direction, not yet the steps. You may purchase commercial Trac support from several places to get your problem sorted out within days, if not hours. Remind that here most of us are volunteering in our spare time just for fun, altruism, ets. Even, if you're a little bit disappointed right now, please share a little of our enthusiasm.

4th, keep an eye on possible unicode and i18n issue. Test without and with non-ASCII chars separately. Translations would only be of concern, if you had Trad 0.12 or later revision. I know, there are some weaknesses in TagsPlugin for what I've learned with other plugins recently, especially regarding full 0.11 backward-compatibility. But this will all get sorted out very soon too - independently of this ticket, but I'll provide a reference to keep you updated.

Almost OT: The severity of edit failure is depending on local settings and the browser make in general. While I've lost a lot of wiki edit work with IE too, this has never been the case for FF and derivatives. Don't know, if switching browsers is an option for your users at all, but I've found almost full text restored when returning to the editor window with my favorite Iceweasel (a Debian GNU/Linux FireFox clone), still YMMV.

No need to do everything right now. Provide relevant information step by step, so we can make it work with some changes to this existing code. Anything else is unrealistic.

comment:2 follow-ups: Changed 3 years ago by mishra.anadi@…

  1. Not a rant. Here to help & really appreciate your work. (Like your misplaced paranoia too).
  2. Trac version 0.11. TagsPlugin vs 0.6
  3. Browser FF. Did not try any other browser.
  4. Will provide more info & more testing in coming week.

comment:3 in reply to: ↑ 2 Changed 3 years ago by hasienda

Replying to mishra.anadi@gmail.com:

  1. Not a rant. Here to help & really appreciate your work. (Like your misplaced paranoia too).

Ok, I'm looking forward to hear details then. (Still no need to like my way of thinking. It's just half-educated guesswork from more than a year of giving support for various plugins here.)

  1. Trac version 0.11. TagsPlugin vs 0.6

Well, so you'll not need coming compatibility-related changes in trunk, but OTOH you'll lack some of the fixes for bugs in 0.6, that have been added to trunk recently. May still give us a valuable hint on what should get backported before the tags-0.7 release.

  1. Browser FF. Did not try any other browser.

Didn't expect this one. So normally your users should be able to resume with edited wiki content recovered after a save failure. Wired. However, better let us fix the issue.

comment:4 follow-up: Changed 3 years ago by rjollos

comment:5 in reply to: ↑ 4 Changed 3 years ago by hasienda

Replying to rjollos:

Duplicate of #7525?

Kind of, still the description is somewhat unclear until now. Let's wait a bit longer, if the reporter can provide more details.

But there is #3145 too, that claims it has been fixed in development after tractags-0.6 (see current changelog). A regression? I've been unable to reproduce this with current trunk, so I'd rather recommend to go with trunk before the next release anyway.

comment:6 Changed 3 years ago by hasienda

  • Cc rjollos otaku42 added
  • Priority changed from high to normal

Step down priority, since the complains raised here haven’t been verified and updated according to immediate request.

Still waiting for details and feeling, that my initial, blamed "misplaced paranoia" actually wasn't that misplaced.? In fact, we've got the copy-tags-from-template (#3753) to work reliably, so this is even more unlikely to be a current issue.

The only way I can think of a valid claim is, if it would turn out to be a 0.11 backwards-compatibility issue. Would love to rule this out as well.

comment:7 Changed 3 years ago by hasienda

  • Priority changed from normal to low

Sorry, can't think of a valid claim that stays that long without more confirming details.

My initial paranoia about the issue has proven to be very reasonable - just by time, right? While I'd like to resolve the issue for the OP, there's still nothing to work with here. Sorry, but I'll be closing this down at or before the next release, if the report is left in the current state for a few more weeks.

comment:8 in reply to: ↑ 2 Changed 21 months ago by hasienda

  • Keywords wiki change added
  • Severity changed from blocker to major

Replying to mishra.anadi@gmail.com:

  1. Not a rant. Here to help & really appreciate your work. (Like your misplaced paranoia too).

Oh, well. While we've resolved many more issues since late 2011, obviously you've been unable to follow-up even with a short test summary within more than a year now. Judge yourself, but I'm feeling approved here. Therefor even "only" 'critical' priority rating couldn't hold any longer.

Nevertheless I would have loved to stand corrected, only that 'no reply' is the single most common pattern observed here, when developers request more information from ticket authors. But you're still standing out by providing a real email, so there's at least a chance to reach you with ticket comments.

  1. Trac version 0.11. TagsPlugin vs 0.6

We'll release next stable rather soon. tags-0.6 is largely obsoleted, and you should only try trunk code for now.

  1. Will provide more info & more testing in coming week.

See comment on 1. above.

comment:9 Changed 5 months ago by hasienda

  • Resolution set to fixed
  • Status changed from new to closed

In 13815:

TagsPlugin: Completing preparation for v0.7 release.

Availability of that code as stable, tagged release
closes #2429, #3359, #3610, #3624, #3677, #3754, #3864, #3947, #3983, #4078, #4277, #4503, #4799, #5523, #7787, #7857, #8638, #9057, #9058, #9059, #9060, #9061, #9062, #9063, #9149, #9210, #9521, #9630, #9636, #10032, #10416, #10636, #11096, #11147, #11152, #11274, #11302, #11658 and #11659.

Additionally there are some issues and enhancement requests showing progress,
but known to require more work to resolve them satisfactorily, specifically
refs #2804, #4200, #8747 and #9064.

Thanks to all contributors and followers, that enabled and encouraged a good
portion of this development work.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.