Modify

Opened 8 years ago

Closed 6 months ago

Last modified 6 months ago

#4200 closed enhancement (fixed)

[Patch] Some enhancements that may be helpful

Reported by: georgesoon Owned by: Steffen Hoffmann
Priority: normal Component: TagsPlugin
Severity: normal Keywords: casing query
Cc: Michael Renzmann Trac Release: 0.11

Description

features:

  • query is not case sensitive
  • page content change along with tag change in one submit
    • in 0.6, only tag change in wiki page takes effect
    • content change is lost
  • collect tag from any custom field

changeset

  • api.py
  • ticket.py
  • query.py
  • wiki.py

Attachments (5)

api.py (9.7 KB) - added by georgesoon@… 8 years ago.
for case insensitive
query.py (13.0 KB) - added by georgesoon@… 8 years ago.
for case insensitive
ticket.py (6.2 KB) - added by georgesoon@… 8 years ago.
for custom fields and case insensitive
wiki.py (5.9 KB) - added by georgesoon@… 8 years ago.
for page content and tag change in one submit
my-patch.diff (8.6 KB) - added by georgesoon@… 8 years ago.
svn diff

Download all attachments as: .zip

Change History (17)

Changed 8 years ago by georgesoon@…

Attachment: api.py added

for case insensitive

Changed 8 years ago by georgesoon@…

Attachment: query.py added

for case insensitive

Changed 8 years ago by georgesoon@…

Attachment: ticket.py added

for custom fields and case insensitive

Changed 8 years ago by georgesoon@…

Attachment: wiki.py added

for page content and tag change in one submit

comment:1 Changed 8 years ago by Alec Thomas

Please provide your change as a patch. You can generate one from within an svn checkout with:

svn diff > my-patch.diff

Changed 8 years ago by georgesoon@…

Attachment: my-patch.diff added

svn diff

comment:2 Changed 8 years ago by Ryan J Ollos

Summary: some enhancements may be helpful[Patch] Some enhancements that may be helpful

comment:3 in reply to:  description Changed 7 years ago by Michael Renzmann

Owner: changed from Alec Thomas to Michael Renzmann

Replying to georgesoon:

  • page content change along with tag change in one submit
    • in 0.6, only tag change in wiki page takes effect
    • content change is lost

This had been reported in #3206 and has just been fixed in r7372.

For the rest: could you please provide one patch per new feature, rather than one patch per changed file? That'd make it a lot easier to review the changes in context.

comment:4 Changed 7 years ago by Adrian Fritz

Reassign to new maintainer.

comment:5 Changed 7 years ago by Steffen Hoffmann

See #4799 for another take on case-insensitive behavior, but this time with configuration option to retain old/default case-sensitive behavior, that should definitely be considered.

comment:6 Changed 6 years ago by Steffen Hoffmann

Keywords: casing query added
Owner: changed from Michael Renzmann to Steffen Hoffmann

I'll take care for it as my time permits.

comment:7 Changed 6 years ago by Steffen Hoffmann

Cc: Michael Renzmann added; anonymous removed

comment:8 Changed 6 years ago by Steffen Hoffmann

(In [10736]) TagsPlugin: Allow mixing of upper- and lower-case tags in sorted tags cloud, refs #4200 and #4799.

This is controlled by a new option cloud_caseless_sort that defaults to False for backwards-compatibility and doesn't touch the more general issue of case-sensitive tag handling (in TagsQuery) as detailed in #4200.

Thanks to Jeff Hammel for contributing the code for this enhancement.

comment:9 Changed 3 years ago by Steffen Hoffmann

In 13815:

TagsPlugin: Completing preparation for v0.7 release.

Availability of that code as stable, tagged release
closes #2429, #3359, #3610, #3624, #3677, #3754, #3864, #3947, #3983, #4078, #4277, #4503, #4799, #5523, #7787, #7857, #8638, #9057, #9058, #9059, #9060, #9061, #9062, #9063, #9149, #9210, #9521, #9630, #9636, #10032, #10416, #10636, #11096, #11147, #11152, #11274, #11302, #11658 and #11659.

Additionally there are some issues and enhancement requests showing progress,
but known to require more work to resolve them satisfactorily, specifically
refs #2804, #4200, #8747 and #9064.

Thanks to all contributors and followers, that enabled and encouraged a good
portion of this development work.

comment:10 Changed 12 months ago by Ryan J Ollos

Owner: Steffen Hoffmann deleted

comment:11 in reply to:  description Changed 6 months ago by Ryan J Ollos

Resolution: fixed
Status: newclosed

Replying to georgesoon:

  • collect tag from any custom field

This is the only request that hasn't already been handled in this ticket, and it's a duplicate of #2804.

comment:12 Changed 6 months ago by Ryan J Ollos

Owner: set to Steffen Hoffmann

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Steffen Hoffmann.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.