Modify

Opened 6 years ago

Closed 6 months ago

#9805 closed enhancement (duplicate)

Force user to add their own or otherwise accept a default license

Reported by: Ryan J Ollos Owned by: Michael Renzmann
Priority: normal Component: TracHacks
Severity: normal Keywords: license
Cc: Steffen Hoffmann, Odd Simon Simonsen Trac Release: 0.11

Description

Plugins with no license are, IMO, a major problem for trac-hacks. See for example, #9804.

Handing over maintainership for such plugins, or even using them, is problematic. The NewHackMacro should have a step that forces a user to input or select a license. Since Trac has a BSD license, it seems appropriate that the default license would be BSD, if the user doesn't explicitly select a different license. Tags (e.g. bsd, gpl, beerware) should be added so that users can easily filter plugins by license.

In the meantime, I've started adding the nolicense tag to plugins that are completely missing a license.

Results (1 - 100 of 174)

1 2
  • #9745 task: Plugin needs a license (closed: fixed)
  • #9806 enhancement: Plugin needs a license (closed: fixed)
  • #9808 enhancement: Plugin needs a license (closed: fixed)
  • #9809 enhancement: Plugin needs a license (closed: fixed)
  • #9813 enhancement: Plugin needs a license (closed: fixed)
  • #9815 enhancement: Macro needs a license (closed: fixed)
  • #12210 task: License and Source (closed: fixed)
  • #12223 task: Plugin needs a license (closed: fixed)
  • #12229 task: Plugin needs a license (closed: fixed)
  • #12230 task: Plugin has no license (new)
  • #12268 task: Plugin needs a license (closed: fixed)
  • #12316 defect: Plugin has no license (new)
  • #12317 defect: Plugin has no license (closed: wontfix)
  • #12318 task: Plugin has no license (new)
  • #12319 task: Plugin has no license (new)
  • #12320 task: Plugin has no license (new)
  • #12321 task: Plugin has no license (closed: fixed)
  • #12322 task: Plugin has no license (closed: fixed)
  • #12323 task: Plugin has no license (new)
  • #12324 task: Plugin has no license (new)
  • #12325 task: Plugin has no license (closed: wontfix)
  • #12326 task: Plugin has no license (new)
  • #12327 task: Plugin has no license (closed: fixed)
  • #12328 task: Plugin has no license (new)
  • #12329 task: Plugin has no license (closed: wontfix)
  • #12330 task: Plugin has no license (closed: wontfix)
  • #12331 task: Plugin has no license (new)
  • #12332 task: Plugin has no license (new)
  • #12333 task: Plugin has no license (new)
  • #12334 task: Plugin has no license (new)
  • #12335 task: Plugin has no license (closed: fixed)
  • #12336 task: Plugin has no license (new)
  • #12337 task: Plugin has no license (new)
  • #12338 task: Plugin has no license (new)
  • #12339 task: Plugin has no license (new)
  • #12340 task: Plugin has no license (new)
  • #12341 task: Plugin has no license (new)
  • #12342 task: Plugin has no license (closed: wontfix)
  • #12343 task: Plugin has no license (new)
  • #12344 task: Plugin has no license (new)
  • #12345 task: Plugin has no license (new)
  • #12346 task: Plugin has no license (new)
  • #12347 task: Plugin has no license (new)
  • #12348 task: Plugin has no license (closed: wontfix)
  • #12349 task: Plugin has no license (new)
  • #12379 task: Plugin has no license (new)
  • #12380 task: Plugin has no license (new)
  • #12386 task: Plugin has no license (closed: fixed)
  • #12387 task: Plugin has no license (new)
  • #12392 task: Plugin has no license (new)
  • #12397 task: Plugin has no license (new)
  • #12398 task: Plugin has no license (new)
  • #12399 task: Plugin has no license (closed: wontfix)
  • #12400 task: Plugin has no license (new)
  • #12401 task: Plugin has no license (new)
  • #12402 task: Plugin has no license (new)
  • #12419 defect: Plugin license (closed: fixed)
  • #12441 task: Plugin has no license (new)
  • #12442 task: Plugin has no license (new)
  • #12448 task: Plugin has no license (new)
  • #12453 task: Plugin has no license (new)
  • #12456 task: Plugin has no license (closed: fixed)
  • #12495 task: Plugin has no license (assigned)
  • #12496 task: Plugin has no license (new)
  • #12561 task: Plugin has no license (new)
  • #12562 task: Plugin has no license (new)
  • #12565 task: Plugin has no license (new)
  • #12801 task: Plugin has no license (closed: fixed)
  • #12845 defect: Missing LICENSE file (closed: fixed)
  • AnchorMacro Add an anchor to any text
  • AnjLabSyncItPlugin Outlook task management integration
  • ArbitraryProjectPropertiesPatch Patch Trac to allow Arbitrary Project Properties
  • AstuteSvcIntegration Generic Windows Service Installer
  • AuthzGroupsPlugin Reuse groups from SVN authz file for user permissions in Trac
  • BranchTimelinePlugin Filter timeline by a specified branch
  • BrowserSvnOperationsPlugin Manage Subversion files from within the Trac browser
  • BurndownPlugin Scrum burndown with support for re-estimates
  • CityTracScript Conversion Script for Project Sycamore wikis
  • CkEditorPlugin Add CKEditor Wysiwyg features in Trac wiki
  • ComponentDependencyPlugin Allows a component to state dependencies on other plugins
  • ComponentsProcessorMacro List project components with descriptions
  • ContactInfoPlugin Set contact information for a Trac project
  • DailyReminderScriptForTracScript Daily email to remind owners of open tickets
  • DefaultColsPlugin Add columns with default values to query output
  • EarnedValueChartMacro Add an Earned Value Chart to wiki pages
  • EclipseTracPlugin Eclipse Trac Integration
  • EggdropTicketInfoIntegration Supply ticketinfo in IRC using eggdrop
  • ExcelReportPlugin MS-Excel (xls) report generation
  • ExtendedcamelcasePlugin Automatically create links for words in camelCase
  • ForcePreviewPlugin Require users to preview ticket and wiki changes before submission
  • GnomeBrTheme GnomeBR theme
  • GoogleChromeExtentionPlugin Google Chrome Extension displays new tickets automatically
  • GoogleTranslateTimelineScript Language translation of changeset messages in timeline using Google Language API
  • HeadLinkMacro Insert <link> tags in the <head> of a wiki page
  • ImageListMacro Table of available images with use syntax
  • InsertElementMacro Insert HTML Elements
  • JabberTracScript Import Jabber-muc logs
  • LatexFormulaMacro Render Latex formula to image
  • LightGreenTheme Light Green Theme
  • ListTracProjectsMacro Display tabulated list of Trac projects
1 2

Attachments (0)

Change History (6)

comment:1 Changed 6 years ago by Ryan J Ollos

Keywords: license nolicense added
Owner: changed from Ryan J Ollos to Michael Renzmann

comment:2 Changed 5 years ago by Ryan J Ollos

Cc: Odd Simon Simonsen added
Summary: Force user to add or accept a default licenseForce user to add their own or otherwise accept a default license

Until we have a better system in place as part of the TracHacksPlugin, I'll be creating tickets on an per-case basis for new plugins that don't have the desired level of license clarity. #10860 is an example.

comment:3 in reply to:  description Changed 4 years ago by Ryan J Ollos

Replying to rjollos:

Tags (e.g. bsd, gpl, beerware) should be added so that users can easily filter plugins by license.

The tags I've been using are: bsd-license, gpl-license, apache-license, beerware-license, mit-license, boost-license, creativecommons-license, lgpl-license.

I've not made an attempt so far to distinguish among the various forms of the BSD and GPL licenses, with the exception of LGPL (and I don't think I've been consistent with that one; there are likely many LGPL-licensed plugins tagged with gpl-license).

comment:4 in reply to:  description ; Changed 3 years ago by Ryan J Ollos

Replying to rjollos:

The NewHackMacro should have a step that forces a user to input or select a license.

This will be handled in #11660.

This ticket will be left open until all of the plugin pages have been reviewed and tagged one of the license tags, or the nolicense tag.

comment:5 Changed 2 years ago by Ryan J Ollos

Keywords: nolicense removed

comment:6 in reply to:  4 Changed 6 months ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

Replying to rjollos:

This ticket will be left open until all of the plugin pages have been reviewed and tagged one of the license tags, or the nolicense tag.

See TracHacks/SiteMaintenance#Pluginswithoutlicense.

Closing as a duplicate of #11660.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Michael Renzmann.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.